GadgetsMenu [1.8 - 1.19.2] [Premium]

SpigotVIP GadgetsMenu [1.8 - 1.19.2] [Premium] 5.2.8

No permission to download
◦•●❤♡ ᴄᴏɴᴛᴀᴄᴛ ꜱʜɪᴍᴍᴇʀᴇɴᴄᴇ#5219 ꜰᴏʀ ꜱᴜᴘᴘᴏʀᴛ ♡❤●•◦

Native Minecraft Version:
1.13
Tested Minecraft Versions: 1.8 /1.12 / 1.13 / 1.14 / 1.15 / 1.16 / 1.17 / 1.18 / 1.19
Contributors: Yap Zhen Yie, NoteBlockAPI(xxmicloxx)
Languages Supported: Simplified Chinese, German, Spanish, Polish, Czech
Donation Link: https://paypal.me/zhenyie

[IMG]
[IMG][IMG][IMG][IMG][IMG][IMG][IMG]
Test Server

mc.yapzhenyie.com
Thanks to ShockByte

[IMG]

GadgetsMenu is an advanced cosmetics plugin that provide tons of the features & cosmetics. It has Hats, Animated Hats, Particles, Suits, Gadgets, Pets, Miniatures, Morphs, Banners, Emotes, Cloaks and Mystery Boxes. Cosmetic items can be gained by using Mystery Dust to purchase or open a Mystery Box. You can give specific cosmetics to players with a donor rank to make them feel special comparing to normal players. Most of the settings can be configured and customized in the corresponding files. With this plugin, you can do anything that you could think about it.

See the article on Why Premium?

What're the differences between Premium and Free version?

[IMG]

  • 22+ Miniatures can be unlocked.
  • More than 550+ cosmetic items can be unlocked.
  • Unlocked cosmetic item will be saved in MySQL/SQLite.
  • You can create custom Mystery Boxes loots. :eek:
  • The anti lag system keeps your server lag free. Unequip online players cosmetics and disable the usage of cosmetics if server is running on low TPS.
  • Cosmetics usage can be disabled in certain regions.
More features will be added in Premium version.

[IMG]
  • Contains lots of cosmetics such as Hats, Animated Hats, Particles, Suits, Gadgets, Pets, Miniatures, Morphs(Requires Lib's Disguises), Banners, Emotes & Cloaks.
  • More than 550+ cosmetic items can be unlocked.
  • You can create your own cosmetic items! (Hats, Animated Hats, Particles, Banners & Emotes)
  • Cosmetic items have 4 different types of rarity: Common, Rare, Epic, Legendary.
  • Included a great purchase system, able to unlock cosmetic items with Mystery Dust.
  • Unlocked cosmetic item will be saved in MySQL/SQLite. (MySQL is highly recommended)
  • Auto equip cosmetic item after purchased.
  • Display custom item if player do not have permission of that cosmetic.
  • Item cost discount with specific permission.
  • Unlock cosmetic items with Mystery Boxes.
  • Open Multiple Mystery Boxes at the same time.
  • You can create custom Mystery Boxes loots. :love:
  • Give player's Mystery Boxes with random chances.
  • There're 5 types of Mystery Boxes: , ✰✰, ✰✰✰, ✰✰✰✰ & ✰✰✰✰✰.
  • More than 7 Mystery Vault Animations can be used.
  • You can send Mystery Gifts to online players.
  • Give player's menu selector when they join the server.
  • The anti lag system keeps your server lag free. Unequip online players cosmetics and disable the usage of cosmetics if server is running on low TPS.
  • You can rename your pet's name.
  • Most of the settings can be modified in configurations.
  • All messages can be customized.
  • Supported 3rd currency system. (Vault, PlayerPoints, CoinsAPI) You can create your own custom currency system via API too.
  • Supported for multi-worlds. (Can be modify in config)
  • Cosmetic usage can be disabled in certain regions. (Requires WorldGuard)
  • Automatically sync selected cosmetics when player log into the server. Supported for multiple servers too. (Required MySQL enabled)
  • 2 different ways to store player data. (SQLite & MySQL)
  • Supported Placeholders for plugins that supports PlaceholderAPI placeholders. (Requires PlaceholderAPI)
  • Automatically check for new updates.
  • Provide developer API.
  • Supported spigot version 1.8.8, 1.9.4, 1.10, 1.11, 1.12, 1.13.2, 1.14, 1.15, 1.16, 1.17 & 1.18.

Miniatures
(Reindeer Miniature, Devil Miniature, Snowman Miniature, Snowglobe Miniature)


[IMG]
Got an issue/bug wanted to report or feature you want to suggest? Please open an issue on GitHub issue tracker. Please don't post bug reports/suggestions in the review section. The best way is to post an issue report on GitHub issue tracker or in the discussion section.

Having trouble? Check our Wiki pages or FAQ page to find an answer.
Looking for other language translations?


If you just have a question, you can join our Discord server. You may find a people to assist you or solve your problem.

[IMG]

[IMG]
  1. Buy and download the GadgetsMenu.jar file. You can find the latest versions here.
  2. Morphs is required Lib's Disguises plugin. Download Lib's Disguises plugin if you want to enable Morphs. (Click here for more details)
  3. Place the GadgetsMenu.jar in your plugins directory.
  4. Stop & start your server, and allow the configuration to be generated.
  5. Stop your server, and configure whatever you want.
  6. Start your server again.
For better user experience, it's not recommended to update GadgetsMenu [Premium] from the Free version. The configurations are different and you may get deprecated settings that no longer use in the premium version. However, updating from free version is still compatible and the file configuration will be updated automatically.

You can find a complete list of commands & permissions on GitHub Wiki.
Author
shimmer
Downloads
4,239
Views
4,239
Extention type
jar
File size
2.6 MB
Hash
6f5ef040ce100dcb280325aa5f02408c
First release
Last update
Rating
4.08 star(s) 24 ratings

More resources from shimmer

Latest updates

  1. N/A

    N/A
  2. 5.2.8

    5.2.8
  3. 5.2.6

    5.2.6

Latest reviews

Great!
Possible to update it to the latest version?
Can confirm also, plugin is not loading.

https://pastebin.com/x5XZxjRK
Hi !

I've downloaded the plugin from here, but when starting my server the plugin is disabled because SQLite connection is closed.
Excellent leak, but this version throws out NoClassDefFoundError errors, the latest version fixes this. please update.
UPDATE TO 4.6.2 FOR 1.16.4 VERSION!! <3
Disables itself on load.
Working fine
Yep. It disables itself on load
The plugin is updated but:

If I start it normally when the server is starting it crashes without any errors.

If I try to enable it manually with a plugin it appears:

java.lang.NullPointerException: null
at com.yapzhenyie.GadgetsMenu.cosmetics.pets.TypeManager.register(TypeManager.java:96) ~[?:?]
at com.yapzhenyie.GadgetsMenu.cosmetics.pets.TypeManager.initializePets(TypeManager.java:18) ~[?:?]
at com.yapzhenyie.GadgetsMenu.GadgetsMenu.onEnable(GadgetsMenu.java:257) ~[?:?]
at org.bukkit.plugin.java.JavaPlugin.setEnabled(JavaPlugin.java:264) ~[server.jar:git-Spigot-dcd1643-e60fc34]
at org.bukkit.plugin.java.JavaPluginLoader.enablePlugin(JavaPluginLoader.java:337) [server.jar:git-Spigot-dcd1643-e60fc34]
at org.bukkit.plugin.SimplePluginManager.enablePlugin(SimplePluginManager.java:403) [server.jar:git-Spigot-dcd1643-e60fc34]
at com.rylinaux.plugman.util.PluginUtil.enable(PluginUtil.java:62) [PlugMan.jar:?]
at com.rylinaux.plugman.command.EnableCommand.execute(EnableCommand.java:127) [PlugMan.jar:?]
at com.rylinaux.plugman.PlugManCommandHandler.onCommand(PlugManCommandHandler.java:95) [PlugMan.jar:?]
at org.bukkit.command.PluginCommand.execute(PluginCommand.java:44) [server.jar:git-Spigot-dcd1643-e60fc34]
at org.bukkit.command.SimpleCommandMap.dispatch(SimpleCommandMap.java:141) [server.jar:git-Spigot-dcd1643-e60fc34]
at org.bukkit.craftbukkit.v1_12_R1.CraftServer.dispatchCommand(CraftServer.java:648) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.PlayerConnection.handleCommand(PlayerConnection.java:1399) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:1234) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(PacketPlayInChat.java:45) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.PacketPlayInChat.a(PacketPlayInChat.java:1) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.PlayerConnectionUtils$1.run(SourceFile:13) [server.jar:git-Spigot-dcd1643-e60fc34]
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_261]
at java.util.concurrent.FutureTask.run(Unknown Source) [?:1.8.0_261]
at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:748) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:406) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:679) [server.jar:git-Spigot-dcd1643-e60fc34]
at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:577) [server.jar:git-Spigot-dcd1643-e60fc34]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_261]




Please help me to fix it, or update this plugin.
Very nice leak, but plugin not load

https://prnt.sc/u9oe7q

Similar resources

GadgetsMenu [1.8 - 1.13.2] [Premium] HovR
More than 530+ cosmetic items! Animated Hats, Suits, Gadgets, Miniatures, Cloaks and many more.
3.80 star(s) 5 ratings
Downloads
795
Updated
GadgetsMenu [1.8 - 1.16.4] [Premium] Mayower
More than 550+ cosmetic items! Animated Hats, Suits, Gadgets, Miniatures, Cloaks and many more.
0.00 star(s) 0 ratings
Downloads
517
Updated
GadgetsMenu [1.8 - 1.16.4] [Premium] Blurs
More than 550+ cosmetic items! Animated Hats, Suits, Gadgets, Miniatures, Cloaks and many more.
4.25 star(s) 4 ratings
Downloads
1,197
Updated
Top